souci php5.4< Sujet précédent  Sujet suivant >
Index du Forum -> NUKED-KLAN VERSION > 1.7 -> Généralités

Page : 1 2 3 [4] 5
AuteurMessage
France.gif abbe
Senior Member



Messages : 517
Inscrit(e) le: 03/04/2008
RE : souci php5.4

Je pense que notre staff NK est bien consient de cette situation... Certains hebergeurs ont déjà fait le choix de ne plus supporter les versions inferieur à php 5.5...

 

Il n'y a plus qu'a espéré que cette nouvelle version d'nk voit le jour rapidement afin d'éviter de perdre du monde en route... :/.

 

En attendant, même si ovh insiste pour que leur clients passent sur des nouvelles version de php, n'est pas trop de crainte sur la durée du support... NK n'est pas le seul applicatif à tourner sur une version obsolète de php... Dans le milieu pro, il y a des tonnes d'applicatifs qui tournent sur des versions encore plus obsolete et qui ne sont pas prêt de migrer du jour au lendemain... Et OVH le sait bien... Ils préparent la migration et finirons par donner un ultimatum... Mais je ne pense pas qu'ils puissent arrêter le support des anciennes version de php avant 2016 voir 2017 étant donné la masse de clients pro qu'ils ont... Je pense qu'NK aura migré bien avant à n'en pas douter ! Wink (un ? Very Happy)



Réglement (pour ne pas le perdre de vue ^^). Je ne suis pas développeur, je suis bidouilleur ! :)

Posté le 13/02/2015 - 11:06:30   Revenir en haut | Permalien
France.gif julien123
Junior Member



Messages : 13
Inscrit(e) le: 30/01/2015
RE : souci php5.4

Merci @Zdav et @abbe  , je vais patienter en attendant le patch sauveur Smile...



Jeux : Battlefield 4,3 - Jeux attendus : Hardline, Overwatch

Posté le 13/02/2015 - 21:57:11   Revenir en haut | Permalien
France.gif Keneda
Member



Messages : 197
Inscrit(e) le: 09/05/2008
RE : souci php5.4

Patch PHP 5_4 pour NK 1.7.9 : http://www.nuked-klan.org/index.php?file=Forum&page=viewtopic&forum_id=6&thread_id=4432&p=2#36900

Décompresser et coller les fichiers à la racine de votre FTP (même si ça devrait se passer sans soucis, comme pour toute modif, faire une sauvegarde avant hein, on sait jamais, surtout si vous avez fait des modifs sur votre site, ce pâtch est basé sur une version 1.7.9 de base!)



Posté le 04/03/2015 - 16:51:27   Revenir en haut | Permalien
France.gif julien123
Junior Member



Messages : 13
Inscrit(e) le: 30/01/2015
RE : souci php5.4

@Keneda   :    Merci , je l'ai fait et tout semble OK ! Super !



Jeux : Battlefield 4,3 - Jeux attendus : Hardline, Overwatch

Posté le 07/03/2015 - 00:17:49   Revenir en haut | Permalien
France.gif Plumeex
Junior Member



Messages : 58
Inscrit(e) le: 29/04/2012
RE : souci php5.4

Keneda : mon hébergeur passera à 5.4 d'ici quelques heures. J'ai appliqué ton patch, pour l'instant tout fonctionne, on verra après le changement Very Happy

 

Par contre j'utilise le module Page, qui n'est pas inclus dans ton patch. J'espère qu'il ne va pas me faire défaut... On va bien voir.

EDIT : ça fonctionne à merveille, pas d'inquiétude donc Smile

 

Merci pour tout ce boulot !



Edité par Plumeex le 20/03/2015 - 19:59:28

Oooooooooh.

Posté le 20/03/2015 - 00:15:57   Revenir en haut | Permalien
France.gif naru01
Ancien

Messages : 588
Inscrit(e) le: 20/03/2010
RE : souci php5.4

Salut !

J ai modifié le module page. En espérant que ce soit bon.



<p><a href="irc://irc.noxether.net/nuked-klan" target="_blank"><img alt="signature naru01" src="http://img15.hostingpics.net/pics/298925signature.png" style="height:150px; width:450px" title="signature naru01" /></a></p> <p>&nbsp;</p>
Posté le 21/03/2015 - 09:44:25  f0def2c138.rar (6 Ko) Revenir en haut | Permalien
France.gif Keneda
Member



Messages : 197
Inscrit(e) le: 09/05/2008
RE : souci php5.4
Citation par Plumeex :

n'est pas inclus dans ton patch.

Je tiens à préciser que ce n'est pas mon patch, c'est celui de Samoth Wink

Je n'ai fait qu'aggréger les fichiers qu'il a modifiés pour permettre une installation rapide et facile par la communauté, en gros, j'ai pas foutu grand chose si ce n'est du report de bug et de l'aide au débbug.

Rendons à Samoth ce qui lui appartient Lol



Posté le 08/05/2015 - 10:23:18   Revenir en haut | Permalien
France.gif Yellux
Ancien

Messages : 59
Inscrit(e) le: 13/10/2008
RE : souci php5.4

Pour le probleme d'encodage, pourquoi ne pas juste rajouté en haut du fichier index.php a la racine du cms

ini_set('default_charset', 'ISO8859-1'Wink;

Ca evite de tout modifier Razz



Posté le 05/08/2015 - 23:34:56   Revenir en haut | Permalien
France.gif mike74
Member



Messages : 211
Inscrit(e) le: 16/02/2009
RE : souci php5.4

Salut le problème cela et juste une rustine si cela fonctionne, c'est pour cela qu'il y a des dévelopeurs et des bidouilleurs , dans notre jargon, les bidouilleurs trouve une solution provisoire dans le bon sens ou le mauvais selon le chapeau, tendis que les dévelopeurs trouve eux une solution durable ce qui et préférable et plus sur car le provisoire ne dure pas malheureusement et les développers eux sont spécialiser dans leurs fonctions et sont les plus aptes a trouver la meilleur des solutions dans tous les cas, qui resteras de toute façon  la meilleur car il maitrise leur sujet dans leur domaine , c'est  leur terrain de jeux Wink, ils sont de  toute façon  capable de pleins de chose du devellopeur au modérateur  mais sont diviser par je ne sait pas quoi malheureusement le manque de motivation ou le manque de confiance en soi ou le manque de remerciement ou de reconaissance " dans tous les cas la dessus je les comprends", pourtant NK uni pourais faire de grande chose , mais cela ne dépend que d'eux le staff  et leur amour pour nk et du partage, enfin biz pour tous et a bientot sur ts pour le staff.

 

 

 

 

 

 

 



Edité par mike74 le 07/08/2015 - 23:14:04

Visiter notre site

 

Posté le 07/08/2015 - 22:37:03   Revenir en haut | Permalien
France.gif Plumeex
Junior Member



Messages : 58
Inscrit(e) le: 29/04/2012
RE : souci php5.4

Patch appliqué à nouveau après le passage en 1.7.12 — les accents avaient sauté — ça marche nickel. Smile



Oooooooooh.

Posté le 30/08/2015 - 00:11:07   Revenir en haut | Permalien
France.gif Yellux
Ancien

Messages : 59
Inscrit(e) le: 13/10/2008
RE : souci php5.4

J'ai appliqué les modifications pour le php 5.4 sur la 1.7.12

http://yellux.olympe.in/DOWNLOAD/NK_1.7.12_php_5.4.zip

Je vait le faire pour la sp aussi au passage.

 



Posté le 01/09/2015 - 22:12:33   Revenir en haut | Permalien
France.gif Flux
Member



Messages : 154
Inscrit(e) le: 12/11/2008
RE : souci php5.4
Citation par Yellux :

J'ai appliqué les modifications pour le php 5.4 sur la 1.7.12

http://yellux.olympe.in/DOWNLOAD/NK_1.7.12_php_5.4.zip

Je vait le faire pour la sp aussi au passage.

 

Salut Yellux, 

Est ce que tu sais si la nouvelle version nk 1.7.12 est compatible avec PHP 5.5 ?



» www.weax.net : Hébergeur de site web avec Nuked-Klan pré-installé. 

Posté le 02/09/2015 - 11:45:28   Revenir en haut | Permalien
France.gif naru01
Ancien

Messages : 588
Inscrit(e) le: 20/03/2010
RE : souci php5.4

Je l ai installé sur mon serveur qui est en 5.5 et ça a l air de marcher.

Ca a résolu le problème d accent dans le bloc sondage dans mon cas.



<p><a href="irc://irc.noxether.net/nuked-klan" target="_blank"><img alt="signature naru01" src="http://img15.hostingpics.net/pics/298925signature.png" style="height:150px; width:450px" title="signature naru01" /></a></p> <p>&nbsp;</p>
Posté le 02/09/2015 - 12:24:35   Revenir en haut | Permalien
France.gif Flux
Member



Messages : 154
Inscrit(e) le: 12/11/2008
RE : souci php5.4
Citation par naru01 :

Je l ai installé sur mon serveur qui est en 5.5 et ça a l air de marcher.

Ca a résolu le problème d accent dans le bloc sondage dans mon cas.

ok super Smile



» www.weax.net : Hébergeur de site web avec Nuked-Klan pré-installé. 

Posté le 02/09/2015 - 17:03:25   Revenir en haut | Permalien
Belgium.gif Stive
Communauté

Messages : 1160
Inscrit(e) le: 13/06/2004
RE : souci php5.4

Perso, je viens de réinstaller mon serveur avec mon site PalaceWaR qui date de plus de 10 ans et j'ai rencontré juste un souci d'encodage de caractère que j'ai très vite résolu en ajoutant tout simplement : dans le php.ini

Citation :

default_charset = "ISO-8859-1"

PHP Version : 5.6.12-0+deb8u1



Website : https://bel-cms.be ou https://github.com/BEL-CMS

Website : https://palacewar.eu

Avant d'ouvrir un sujet, n'oubliez pas de lire le règlement et faire une recherche sur le forum !

Posté le 10/09/2015 - 04:17:32   Revenir en haut | Permalien
Page : 1 2 3 [4] 5